TA STRONA UŻYWA COOKIE. Dowiedz się więcej o celu ich używania i zmianie ustawień cookie w przeglądarce. Korzystając ze strony wyrażasz zgodę na używanie cookie, zgodnie z aktualnymi ustawieniami przeglądarki.  [X]
Windows 7, Seven Forum
 
Witamy, Gość. Zaloguj się lub zarejestruj.

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
Aktualności: Oficjalny build: Current Release. Windows 10 Build 9860 | Sklep z oprogramowaniem | Windows7.pl na FB! | Windows 8 News | Poradniki
 

Strony: [1] 2
  Drukuj  
Autor Wątek: Użytkowanie, czarny ekran z kursorem i nic dalej?  (Przeczytany 21501 razy)
localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« : 19 Styczeń 2010, 18:41:44 »

Witam. Przed chwilą, podczas pracy mój komputer włączył wygaszacz ekranu. Po wybudzeniu go z niego, widziałem czarny ekran, dający się przesunąć kursor i nic więcej- na nic nie reagował, nawet na ctrl+alt+del.
Poczekałem kilka minut i postanowiłem go wyłączyć przyciskiem przytrzymanym 6 sekund (to jest laptop).
Od tej pory, laptop się uruchamia, MBR ładuje bootloadera (widzę pozostałości błędowe po MBR), lecz zamiast splasha startowego jest ciągle czarny ekran, nic się nie dzieje przez kilka minut.
W BIOS dysk wygląda normalnie, nie wyskakują przy starcie żadne komunikaty- co się dzieje?!
 ----------------------------
Dziwna sprawa.... żadna z moich płyt z Windowsem nie uruchamia się, tylko bootuje się Linux...
Mam Windowsa 7RC i RTM- nic z tego.
Wirus jakiś? Odpalam właśnie Ubuntu, sprawdzę czy nie ubyło czegoś z dysku i czy w ogóle ten działa...
« Ostatnia zmiana: 19 Styczeń 2010, 18:46:13 wysłane przez localh0st » Zapisane
robert79513
Ekspert
*****
Offline Offline

Wiadomości: 1777



Zobacz profil
« Odpowiedz #1 : 19 Styczeń 2010, 18:51:15 »

Wydaje się to być bardziej problemem z sprzętem niż z systemem czy wirusem.
Zapisane

localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« Odpowiedz #2 : 19 Styczeń 2010, 19:01:01 »

Wygląda na sypniętą partycję C:... o_O

Przy montowaniu tejże partycji otrzymuję taki błąd:
"ntfs_attr_pread ntfs_pread failed"
Druga partycja (D:) montuje się bez problemu...

Czy jeżeli dysk twardy jest uszkodzony, płyta z Windowsem może się nie uruchamiać?
Na tym samym sprzęcie, kilka dni temu wszystko było ok.

Na dysku zainstalowany jest Windows 7 RC (od kwietnia)...
/7077 też się nie bootuje...
« Ostatnia zmiana: 19 Styczeń 2010, 19:08:15 wysłane przez localh0st » Zapisane
robert79513
Ekspert
*****
Offline Offline

Wiadomości: 1777



Zobacz profil
« Odpowiedz #3 : 19 Styczeń 2010, 20:24:02 »

Jeśli dysk twardy jest uszkodzony to może być tak że instalator systemu nie wystartuje. Pobierz program HDD Regenerator wypal sobie płytkę cd za pomocą tego programu i wystartuj z niej. Program powinien naprawić dysk (nie usuwając z niego żadnych danych) jeśli nie jest on mocno uszkodzony.
Zapisane

localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« Odpowiedz #4 : 19 Styczeń 2010, 21:10:37 »

Właśnie się skanuje ten dysk od dwóch godzin z minutami. Sprawdziło ok. 0.70% dysku (1400mb) i wykryło/naprawiło już ponad 600 badów...
Przy 1200mb zatrzymałem proces sprawdzania, uruchomiłem komputer ponownie by sprawdzić czy system startuje- teraz przynajmniej zamiast bootloadera pokazuje się błąd (obecnie winload.exe). Pod Linuksem partycja C: nie jest nadal montowana- mam nadzieję, że gdy cała powierzchnia którą obejmuje C: zostanie sprawdzona nie będzie już błędów.

Tak poza tym- czy taka masa bad sectors na dysku w laptopie, ktora pojawiła się w przeciągu tych ~10 miesięcy użytkowania systemu to dużo?
Zapisane
robert79513
Ekspert
*****
Offline Offline

Wiadomości: 1777



Zobacz profil
« Odpowiedz #5 : 19 Styczeń 2010, 22:03:46 »

Tak to może być jakieś poważniejsze uszkodzenie dysku. 10 miesięcy to stanowczo za mało jak na dysk twardy. Po naprawie może się okazać że te złe sektory znowu się wysypią, a jeśli będzie ok to na pewno system trzeba będzie przeinstalować bo się nie uruchomi nie masz co na to liczyć.
Zapisane

localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« Odpowiedz #6 : 20 Styczeń 2010, 15:20:54 »

Zeskanowałem cały dysk. Wykryło i naprawiłem łącznie ok. 5000 uszkodzonych sektorów, a teraz najlepsze- z paska postępu wychodzi na to, że wszystkie znajdowały się na powierzchni partycji startowej (100mb) i systemowej (100GB), reszta (druga partycja) są czyściutkie i w pełni wolne od błędów.

Spod Linuksa udało mi się podmontować te partycje, wszystko wygląda na to że działa i da się skopiować z nich pliki.

Płyta z Windows 7 (w kilku wersjach) nadal się nie bootuje... wtf? Na drugim komputerze działa, na tamtym nie chce się odpalić. Da się coś z tym zrobić?
Zapisane
robert79513
Ekspert
*****
Offline Offline

Wiadomości: 1777



Zobacz profil
« Odpowiedz #7 : 20 Styczeń 2010, 16:19:21 »

Spróbuj instalacji z pendrive'a.

http://www.windows7.pl/forum/index.php/topic,1415.0.html
Zapisane

localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« Odpowiedz #8 : 20 Styczeń 2010, 18:16:26 »

Chyba będę musiał zrobić całkowite formatowanie i wykonać partycjonowanie...
Z tego co pamiętam, miałem kilka dodatkowych systemów zainstalowanych na tamtym dysku od kwietnia- możliwe że przez rozszerzanie partycji systemowej powstały błędy. Tą partycję D: formatowałem ostatnio jakoś 5 miesięcy temu...
Używałem także laptopa w pociągu i samochodzie kilka razy, a przenosiłem go zazwyczaj w trybie wstrzymania systemu.
~~~~~~~~~~~~~~~~~~~~
Udało mi się zdobyć zewnętrzny dysk, właśnie kopiuję pliki z poziomu Linuksa livecd.
Mam problem- chciałbym skopiować moje pliki konfiguracyjne zawarte w appdata/roaming, lecz gdy otwieram ten folder to jest on pusty - pewnie jest zabezpieczony przed odczytem.
Da się w jakiś sposób obejść to zabezpieczenie i skopiować w jakikolwiek inny sposób ten folder?

~~~~~~~~~~~~~~~~~~~~
Co do bootu z usb: próbowałem odpalić samo recovery Win7 które specjalnie pobrałem- niestety bez skutku.
Dodam, że w 100% sprawna płyta z XP zawiesza się tuż przy samym starcie (podczas bootowania gdy jest napisane by "wcisnąć dowolny klawisz", po kliknięciu wszystko się obecnie zawiesza).

Mam nadzieję, że spod Linuksa uda mi się poprawnie przepartycjonować dysk tak, aby instalator Windowsa się uruchomił.
« Ostatnia zmiana: 20 Styczeń 2010, 18:19:24 wysłane przez localh0st » Zapisane
robert79513
Ekspert
*****
Offline Offline

Wiadomości: 1777



Zobacz profil
« Odpowiedz #9 : 20 Styczeń 2010, 18:47:53 »

Pliki w appdata/roaming są ukryte a co do reszty twojej wypowiedzi to dobrze kombinujesz spartycjonowanie na nowo całego dysku powinno załatwić sprawę. Na przyszłość nie zaśmiecaj komputera kilkoma systemami i to zmieszanymi ze sobą, więcej porządku w kompie zalecam Mrugnięcie Jednak nie jestem do końca pewny czy dysk jest sprawny.
Zapisane

localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« Odpowiedz #10 : 20 Styczeń 2010, 19:19:51 »

Cytuj
Pliki w appdata/roaming są ukryte
Nie da się ich odczytać w jakiś sposób? Szkoda mi stracić konfigurację kilku aplikacji, w tym głównie Firefoksa i sidebara.

Cytuj
reszty twojej wypowiedzi to dobrze kombinujesz spartycjonowanie na nowo całego dysku powinno załatwić sprawę.
Kiedyś miałem problem ze stacjonarnym komputerem. System padał bardzo często (co jakieś dwa tygodnie) przez jakieś pół roku. Reinstalowałem system, formatując tylko partycję C:, dwie pozostałe leżały odłogiem w tym czasie. W końcu zebrałem się na całkowite formatowanie i utworzenie partycji na nowo. Od tamtej pory komputer stacjonarny działa do dzisiaj (hm, jakieś 3 lata już będą). Problem leżał w uszkodzonych sektorach i nie wiem czy też nie w tablicy.

Cytuj
Na przyszłość nie zaśmiecaj komputera kilkoma systemami i to zmieszanymi ze sobą, więcej porządku w kompie zalecam
Porządek jest. Uśmiech
Maksymalnie były to dwa systemy, na początku Windows 7 i Arch Linux, później na miejscu Archa zainstalowałem Leoparda (dla którego też rozszerzyłem partycję zabierając z pozostałych po trochu przestrzeni).

Cytuj
Jednak nie jestem do końca pewny czy dysk jest sprawny.
Miejmy nadzieję, że wszystko jest z nim w porządku. Postaram się udostępnić później zdjęcie pokazujące pasek postępu skanu w HDD Regenerator- ciekawie wygląda, tym bardziej jeżeli wiemy iż partycja systemowa zajmowała 2/5 przestrzeni całkowitej).


Zapisane
robert79513
Ekspert
*****
Offline Offline

Wiadomości: 1777



Zobacz profil
« Odpowiedz #11 : 20 Styczeń 2010, 20:13:38 »

Nie da się ich odczytać w jakiś sposób? Szkoda mi stracić konfigurację kilku aplikacji, w tym głównie Firefoksa i sidebara.

Ja bym użył MiniPE-XT v2k5.09.03 (pierwszy link w google ostatni post Mrugnięcie) jest to system live cd oparty na windows XP nie używam linuksów live cd. To powinno wiedzieć wszystkie ukryte pliki i foldery Mrugnięcie
Zapisane

localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« Odpowiedz #12 : 20 Styczeń 2010, 21:31:48 »

Właśnie spostrzegłem, że Hirens Boot CD ma zintegrowaną starą wersję Acronis True Image. Robię backup całej partycji na dysk zewnętrzny- jak się wszystko uda, to będę mógł się cieszyć wszystkimi plikami z partycji systemowej po reinstalacji systemu.

Ah, dodam że odpaliłem z tej płyty Windowsa XP livecd. Wszystko dobrze, partycję D: czyta i tą zarezerwowaną dla systemu 100Mb, lecz tą systemową C: za nic nie chce. (:
Zapisane
localh0st
Nowy użytkownik
*
Offline Offline

Wiadomości: 26


Zobacz profil
« Odpowiedz #13 : 21 Styczeń 2010, 16:54:39 »

Użyłem chkdsk z XP Livecd... Wykryło masę błędów i wszystkie naprawiło. Teraz przy starcie pokazuje mi się błąd dotyczący \Windows\system32\config\system (jest napisane, że należy naprawić to z płyty instalacyjnej Windowsa - lecz ten nadal się nie bootuje...
Jest jakieś rozwiązanie na to?
Zapisane
robert79513
Ekspert
*****
Offline Offline

Wiadomości: 1777



Zobacz profil
« Odpowiedz #14 : 21 Styczeń 2010, 16:56:53 »

Spróbuj zainstalować system z pendrive'a.
Zapisane

Strony: [1] 2
  Drukuj  
 
Skocz do: